phpmyadmin出現了這樣的錯誤

各位好:

tky用ubuntu自己架了一個伺服器來跑Drupal,上頭LAMP架構一應俱全,同時習慣用phpmyadmin來管理資料庫。
最近給伺服器來個大更新,從7.10版本升級到8.04版,一切大致正常,除了原本可以正常透過帳號密碼登入的phpmyadmin無法正常登入了。首頁只出現
錯誤
設定檔案現在需要密碼 (passphrase) (blowfish_secret).

這樣的字樣。不曉得是怎麼搞得會跑出這個。

google了一下這個錯誤訊息,還蠻常見的。不過嘗試之下各種解法都沒有用。
能否請高人指點一下?感激

tky

ddtet's 的頭像

呃... 個人認為...
你是不是把你試過的方法簡單列出來...

這樣至少能以排除法先確定「不是什麼的問題」,比較好解決這個狀況...

我只是一個撰碼員,靠寫程式過活。
自從 Drupal 在 4.7 版的時候知道他的存在,但是後來跳去其它程式語言很久沒回來。
變成 D5 比較熟,D6 知道一點,D7 還在學的狀況…

sylin's 的頭像

設定一下 phpMyAdmin 的 config.ini 吧

jimmy's 的頭像

config.ini裡頭,blowfish那個設定,隨便打就可以

--
from open mind to open source~

--
from open mind to open source~

tky's 的頭像

不好意思,我把我的問題講清楚一點。

TKY在兩個地方都有找到config.ini.php這個檔案,一個是在/var/lib/phpmyadmin,另一個是在etc/phpmyadmin下面。

/var/lib/phpmyadmin下面有兩個檔案,一個是config.ini.php,裡面的內容是空白的(這是正常的嗎?);另一個是blowfish_secret.inc.php這個檔案,裡頭有一句jimmy所說顯示亂碼的blowfish(不是TKY打的)。

在etc/phpmyadmin下面,有很多檔案,包括config.ini.php,裡頭有一堆參數可以設定,不過TKY就是找不到要去哪裡「亂打」blowfish。

之前google到說可以把blowfish_secret.inc.php丟到etc/phpmyadmin底下去;TKY照做了,但是情況沒有任何的改變。所以至少可以排除掉這個方法。還有人提到改變登入語系,換成簡體中文居然就可以進入。但是TKY換了老半天,都只有看到不同語言的同樣警示碼,也是沒有任何用處。

tky

tky